Saabscene Saab Forum - Saab Technical Information Resource banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,749 Posts
Discussion Starter · #1 ·
Hi folks-

Halfway through the job - box is out! Back again tomorrow to put the new one in. Eurocarparts stiffed me totally on the bits which was annoying, but ended up getting them really cheap from a dealer! Yay!

Anyway, my question to anyone who has fitted the Abbot poly mount to a later type ('94-) car - does it matter which way around it goes?

Also, has anyone figured out a way to lift the box in and out! No lugs on it to connect to
 

·
Registered
Joined
·
8,216 Posts
Originally posted by JohnCC:
[qb]Anyway, my question to anyone who has fitted the Abbot poly mount to a later type ('94-) car - does it matter which way around it goes?[/qb][/b]
I believe so. This is mine, looking from the wheel-arch. It shows the lip to be towards the outside. Mine was pre-production, but I imagine production ones are the same (albeit with the holes moulded properly and not raggedly drilled with a twist-drill)

 

·
Registered
Joined
·
1,749 Posts
Discussion Starter · #6 ·
Ah.. instructions
Didn't spot those! Anyway "the flanged end facing towards the engine bay" doesn't mean much to me and is not as helpful as your picture, so thanks for that!

As for jacking the box up - the car is on small ramps (about 2' elevation) so that makes it harder, but not impossible.

It would be much easier however to lift it from above, if they hadn't removed the lifting tab which Quasi says used to be there

Sure I'll figure something out though
 

·
Registered
Joined
·
1,749 Posts
Discussion Starter · #7 ·
Thanks for the help... it's kind of obvious once you actually come to do it, isn't it?

I borrowed a couple of canvas ratchet straps, for them that are curious, and I reckon with these, an engine hoist, a plank, a jack and some swearing it should go fairly smoothly.

Just for interest, once again marvel at the longevity of the Saab clutch, outlasting gearboxes.

Here is the old one:



And here is the new one:



Pretty good for 96,000 miles - on a London car too!
 

·
Registered
Joined
·
1,749 Posts
Discussion Starter · #8 ·
When I was refitting everything, I read that I should tighten the transmission mount bolt to 50 lb/ft. So, I was doing this and it seemed to be winding a lot, so I stopped and looked, and to my horror, one of the two dish-shaped washers had bent and spread out really badly. I also think I may have bent the tines of the mount on the subframe a little, but it's hard to tell. What did I do wrong??
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top