Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello folks,

I have a 2005 9-3 1.8i. The power steering has become temperamental. It failed about 6 months ago. The connectors were cleaned by the garage. It failed again 1 month ago - the connectors couldn't be resurrected.
I bought a second hand one which failed yesterday .
I'm reluctant to buy a new part as they are over £400...

Am I being unlucky with the parts or could there be something else causing this?

Any tips / advice greatly appreciated.

Cheers,

Angus

Sent from my C6903 using Tapatalk
 

·
Registered
Joined
·
1,169 Posts
Certainly unlucky as the power steering pump electronic or belt driven are not common failures.
Do you have the EHPS or the belt driven version?
Suggest trying a suitable Saab independant specialist for any further work.
What do you mean by "connectors couldnt be resurrected"?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
It's the electronic version. The garage said the connectors in the part were part corroded so they managed to previously get rid of enough corrosion. I checked the forums and it's a common-ish issue caused by water getting in.
There is a saab specialist in Glasgow I'll see if they are still a going concern tomorrow!

Sent from my C6903 using Tapatalk
 

·
Registered
Joined
·
16 Posts
Try Phil Smith in Sheffield, a long way away I know but he may have the part to post and offer advice, excellent bloke with a wealth of SAAB knowledge.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thanks for the advice everyone . I took the car to Schoneville Saab in Glasgow. Turned out the pump was fine ( apparently they rarely fail). It was a wiring issue that they dutifully fixed. I actually saw a similar solution on another forum but I don't have the ability to try these things myself.

Sent from my C6903 using Tapatalk
 
1 - 5 of 5 Posts
Top