Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, my Saab has developed an issue whereby the speedo gets stuck 30/40/50+ miles an hour and rev counter sits at 3500+ at idle.

I have seen some other posts about this but none exactly the same.

Things I have noticed, even though the speedo is reading 130mph and I am doing only 70mph ish (via GPS) the speed alarm I configured will still sound at 75mph (135 on speedo) - so some of the cars brain knows what the real speed is.

There are no ABS warning lights and cruise control continues to work as expected.

Disconnecting the battery or removing the fuse will reset the issue for a while but it seems to come back quicker with this wet weather we've been having.

I understand there is some sort of speed sensor in the left hand rear hub - anyone got a pic of what it looks like or a part number? Are there other speed sensors to look for?

I have heard there is some sort of ECU for speed sensor? Where is this located?

Any tips for troubleshooting / identifying the issue would be great.
 

·
Registered
Joined
·
15 Posts
You are correct with removing fuse.
10 amp third down on the left ( fuse box on left hand side of dash).
Mine did the same a few times but the method i followed was
Ignition to on ( not to start )
Pull fuse.
Replace fuse
Ignition off
Start car.
Seemed to reset gauges.
Hope this helps.
 

·
Super Moderator
Joined
·
3,056 Posts
Normally it's the dash cluster that causes it .
Best corse of action is to
Lift bonnet
Remove key from the ISM ( ignition )
Remove the battery terminals for half an hour
And re-connect the battery
Insert key into ism ( ignition)
Leave in there for 10 seconds to re-sync fob
Repeat with anymore you have
Then turn car on
And re-set anti pinch on front windows .
*Never leave keys in the ISM when pulling fuses as it could cause catastrophic failure of the cars ignition and make it the heaviest paperweight known to man *
 
1 - 3 of 3 Posts
Top