Saabscene Saab Forum - Saab Technical Information Resource banner

1 - 4 of 4 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi everyone,

I wrote a thread on here a few month ago about the issues i was having with my 2002 saab 93 covert. It would not start when warm it would only crank but not fire up. I know alot of people are having this problem. Well the problem is now fixed !!!!! I started by changing the less expensive options first. Had the car serviced (it was due one anyways) so new sparks plugs, fuel filter etc. Still had problem. Next i changed the CPS but this didnt work either. Also have to add that because i need the car daily and having to keep cranking until it fired, i had to get a new starter motor becasue doing this everyday completely knacked it up. I then went to ebay for a coil pack (DI Cassette) and managed to get one second hand for £80. item arrived, i installed and WALLA !!! IT STARTS FIRST TIME EVERY TIME :D

So for all you people who are having this problem, I advise save your money on new CPS etc and go straight for the DIC. I hope this helps.
 

·
Registered
Joined
·
2 Posts
Hi everyone,

I wrote a thread on here a few month ago about the issues i was having with my 2002 saab 93 covert. It would not start when warm it would only crank but not fire up. I know alot of people are having this problem. Well the problem is now fixed !!!!! I started by changing the less expensive options first. Had the car serviced (it was due one anyways) so new sparks plugs, fuel filter etc. Still had problem. Next i changed the CPS but this didnt work either. Also have to add that because i need the car daily and having to keep cranking until it fired, i had to get a new starter motor becasue doing this everyday completely knacked it up. I then went to ebay for a coil pack (DI Cassette) and managed to get one second hand for £80. item arrived, i installed and WALLA !!! IT STARTS FIRST TIME EVERY TIME :D

So for all you people who are having this problem, I advise save your money on new CPS etc and go straight for the DIC. I hope this helps.
I have same issues but already changed the cps twice... fuel pump..ecu...temp sensor.... still exactly the same..really consistent fault.. runs 10 mins no probs, turn off 10 mins later cranks fine but will not start....leave 2 hours....come back starts fine...will also cut out while driving once up to temp.....pulling hair out.. close to scrapping....
 

·
Registered
Joined
·
88 Posts
have you checked all the vacuum and other tubing that runs around the injection system? Can cause sensors to do odd things.
Tried getting a techII scan at a Saab garage or wherever you can find one?
 
1 - 4 of 4 Posts
Top