Saabscene Saab Forum - Saab Technical Information Resource banner
low
1-20 of 326 Results
Advanced
  1. Chat
    Limited performance low fuel pressure have read posts on here but nobody has said what the cause was please help needed
  2. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi Guys my second post, so please excuse if in wrong place. I have a power loss problem on my 2009 ttid, it has the dpf deleted and removed and is chipped to 210 stage one. that is the good news, Power loss above 2750 rpm, it produces no torque up to 4500 rpm. slightly black tail pipes, only...
  3. Classic Saab 9-5 (1997 - 2009)
    Hi all! I have 2001 Saab 9-5, 2.3l MFI Turbo. I have Flashing CEL, low power and shaking engine, aND mis fire in cylinder #2.Trouble codes indicated catalytic converter, and Oxygen sensor. I'm helping my son in law troubleshoot issue. He has replaced cat converter and oxygen sensor to no...
  4. Previous model ranges, FOR SALE and WANTED
    My 2005 Saab 93 Aero convertible. Very low mileage at 72,6000 documented miles with old MOTs to prove. Surplus to requirements as is a third car. 10 months MOT with one minor advisory. Last ( disabled) owner had the car for the past 5 years. In very good condition as you would expect from only...
  5. Classic Saab 9-5 (1997 - 2009)
    Hi There, My 9-5 wagon pushes out white smoke at startup after sitting overnight. Recently, the oil pressure light cam on after driving in town for only about 20 minutes. It has a new turbo and new crankshaft bearings and oil pump. The pump pressure is fine. A mechanic said it was either...
  6. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    2008 1.9 TTid For about a month now I have been getting the "Bing Bong" tone and the message "Low coolant..Add coolant" The car only does this once during warm up (usually when the temp is between a quarter and the normal half way mark).. For the first dozen times it did it I raised the bonnet...
  7. Classic Saab 9-3/GM900 (1994 - 2002)/Conv ( -2003)
    Hi I have a 2001 93 and I noticed it is not pulling as well as it used to, it starts and runs perfectly just not as quick as it used to be. If I disconect and plug the hose going to the turbo wastegate it is back to normal, so I assume the turbo and hoses are fine. I checked the resistance...
  8. Current model range, FOR SALE and WANTED
    My car is near immaculate with 47,000 miles and is a 57 plate with and has full service history. I searched for a long time before buying this car and its with regret I'm having to sell. The new buyer will be getting a very very nice car with subtle upgrades. I am 38 years old and have had many...
  9. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi Guys, just wondering if people had any ideas about this, on the way to lunch today my car stalled twice while sat at idle, i noticed the revs dropped to 500 which then obviously stalled the car on the way back its fine idling at 800 - 900 so my question is does this indicate i may have...
  10. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    OK, so I thought it was a failed spring, and replaced the spring real quick, but the RR LCA is still down and my tire is about worn out on the inside. LCA doesn't look unusual, but I'm ticked and have no idea why the LCA is low and my problem isn't fixed. Any ideas about what the problem is...
  11. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi Folks, My first post. My 11th Saab. Just had 7 years trouble free motoring with a BMW 320d, but it was never a Saab, it was boring and perfect, not like my old 99's and 900's. I've just got hold of a beautiful 08 black Aero convertible, but the dreaded 'bing bong' limited performance...
  12. Tyres, Wheels, and Brakes
    Hi, I have just replaced the front pads and discs on our SAAB 93-2002 convertible and the brake pedal judders (ABS) at very low speeds as if the ABS is kicking in. Any ideas ?
  13. Chat
    Hi all, I have owned a Saab for 6 Months now.. First time I've had one & great comfortable Cars to drive. I have the Saab 93 Sport Wagon 1.9TiD 150Bhp on a 55 Plate. have a few things that need doing to the car but.. have a question for you all. 1. Are Saab's Generally Low riding cars...
  14. Saab 9-3 Sedan/Conv/Combi/TurboX/AWD (2003+)
    Hi Would anyone know why the radio when turned all the wayup, is just audible ?? cd volume is fine thanks andy
  15. Classic Saab 9-3/GM900 (1994 - 2002)/Conv ( -2003)
    Low fan refuses to turn on. Fan resistor replaced. Temp sensor replaced. Fan turns on if ac is on or if temp sensor is disconnected. Tech 2 temp reading from ice unit is lower than the ecu temp sensor. All help welcome.
  16. Classic Saab 9-5 (1997 - 2009)
    Hello all, this is my first post. I am having trouble with my 03 9-5 2.3t linear. All of a sudden my drivers side headlight is out, so i go out and replace both left and right bulbs but it doesn't fix the proble,. Then i go out and buy a new (used) organge relay from ebay with no results. I took...
  17. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi guys, I used the car quite extensively this weekend and today after the last leg of my trip which was about 120 miles the low coolant level message came on on the SID. I stoped and checked the level. (It seemed around the reservoir line when the engine was hot. So I suppose then that it...
  18. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    HI all, A week or so ago my 9-3 stalled comin into a roundabout and when I restarted there was a big reduction in power. It'll drive okay and (just about) overtake but it's still missing a lot of power. It's also become very rough and smokey at startup but once it runs for a couple of minutes...
  19. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi, I currently drive a 2003 Saab 9-3 and have some issues with my headlights. Due to the low functionality of original headlights, I decided to change my headlights to HID (probably 2 years ago). Recently, I've been entering some issues with my headlights. This issue happens specifically...
  20. Classic Saab 9-5 (1997 - 2009)
    Hi, No low beam on right, put in a new bulb & still nothing... The new bulb shows 2.3 ohms so I think it is ok. Would the relay/fuse be bad? In the fuse box under the hood it looks like #7 is for the right... Any other things I should be looking at? Thanks for any help! John
1-20 of 326 Results
Top