Saabscene Saab Forum - Saab Technical Information Resource banner
70mph
1-7 of 8 Results
  1. Classic Saab 9-5 (1997 - 2009)
    Hi. Any clues as to why my 9-5 Aero hits around 70mph & the ABS ESC warning lights etc all light up?? Can drive all day every day urban driving without a problem but hit around 70 onto the motoway and the bing bong sounds and the lights come on the dash! Cheers
  2. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi guys, anyone have any quick simple fixes for this issue?? Wife got back off a long journey the other day and apparently was doing 90mph down our 30mph street...and then was doing 70mph when stationery... I disconnected the battery for 30 mins yesterday to try and reset the issue...but to no...
  3. Saab 9-3 Sedan/Combi/TurboX/AWD(2003+)/Conv(2004+)
    Hi there, I had an odd noise today on my 2007 93 Vector estate. I was doing about 70 mph and turned to the left caused the noise. Its was a slight rumble, low level noise that went on for a second or so then stopped. It did not happen turning to the right or at low speed. I have just had my...
  4. Classic Saab 9-5 (1997 - 2009)
    my 2005 2.3 runs perfectly apart from the last few weeks its been slightly hesitating when cruising on straight flat roads at around 68-72mph with no load on the engine. The revs don't fluctuate, they stay steady at around 2200rpm, only visual clue is the turbo gauge flutters around the white...
  5. Classic Saab 9-3/GM900 (1994 - 2002)/Conv ( -2003)
    Don't know if to describe it as humming as when on motorway today I thought somebody was beeping at me, it only happens above 70mph, there is no vibration from the wheels and it comes and goes, any ideas please.
  6. Tyres, Wheels, and Brakes
    2006 Saab 9-3 1.9 TID Vector I am getting excessive vibration on my steering wheel via front wheels driving after 70mph. I have had the wheels balanced and this has not resolved the problem. Please can anyone advise what it is and solution to resolve? Many Thanks
  7. Classic Saab 9-5 (1997 - 2009)
    Can anyone help me. Its a 98 2.3SE running 215/55/16 Pirelli p6000. Newly fitted. All wheels have been balanced, New front disc's and front and rear wheel bearings. Yet still at 70mph i have a vibration through the car. It does go at 85mph Also under breaking I get severe vibration through the...
1-7 of 8 Results
Top