2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

  1. Welcome to Saabscene – General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
Results 1 to 4 of 4

Thread: 2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

  1. #1

    2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

    Hello All,


    This is my posting and looking forward to your comments - fixing this issue.

    As I stated in the title, I'm having issues starting my 9-3 first start of the day when it's cold outside. Once she has been started, she fires right up throughout the day. During the summer I have no issues starting her.

    I have replaced the battery last month to a higher cold cranking amps - 730
    I had the starter / alternator checked out
    Tuned up the car - Plugs - Coils

    I brought her into a Saab mechanic here in Atlanta to diagnose the issue. The only thing they could see that needed to be done was replacing the timing chain system, as the cheap plastic rails were broken and about to fail 100%

    The same garage did a cold compression test - A valve job will need to be done in the future
    - They also did a ground and draw test all coming up ok.

    It puzzles me that she only struggles when it's cold outside..

    * This past winter she slowly cranked one cold morning, but wouldn't turn-over - I used a battery pack and she fired right up.. This makes me scratch my head

    After reading countless amount of Saab forums about similar issues, I'm seeing that it could be the:
    - Crankshaft Position Sensor?
    - Fuel Pressure? - I will try this today - Turning the key on for 10 seconds > off then on to prime the pump
    - Could the cheap GM valves be the issue? My thinking is- It would run rough and not want to start in any weather..

    Thank you for reading my post, and I look forward to hearing from the community.

    Cheers~!
    Todd

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2

    Re: 2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

    Hello and a warm welcome aboard the good ship saabscene Todd
    i have moved thread into relevant work shop section.
    MSD REGISTER 26101 NOCTURNO-BLAU-MET

  4. #3
    Super Moderator
    Join Date
    Oct 2002
    Location
    Kippen, Stirling
    Posts
    2,681

    Re: 2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

    tantelmi,

    I wouldn't start thinking about anything like valves, cps etc. until you have your slow cranking sorted. It isn't starting 'cause it isn't cranking fast enough. You say that your battery tests out OK and that, with an extra battery pack it starts fine. I'd check your main power connections. The main red cable going from the battery direct to the starter motor. Clean them up. Also the main earth to the chassis and from the chassis to the engine block. I think it goes onto the gearbox. This one often corrodes away.

    Once all this is OK then you are looking at poor connections in the starter motor. This is of the 'pre-engaged' type where the ignition switch powers a solenoid on top of the starter. This activates an electro magnet that pulls the starter gear into engagement. As this comes in it 'makes' another switch that actually puts power to the starer motor. If the contacts are pitted or dirty then the resistance will be high and cranking speed poorer. I think there is a way of checking the resistance as you crank but I can't remember quite how at present.

    Paul @ Kippen

  5. #4
    Saab Newbie
    Join Date
    Jun 2018
    Location
    Hamilton, New Zealand
    Posts
    16

    Re: 2010 9-3 - Hard Time Starting Under 60 Degrees Ambient Temprature

    I'll start the post by stating mine is a diesel. Because yours is a petrol and only on cold starts, this could be the relevance. What I describe can relate to any fuel.
    Mine always, first cranking doesn't matter time of day hot or cold. Just first cranking was sluggish when the engine was cold.
    All the usual checks and some fixes, as Paul has previously said.
    Took it to an Auto Electrician, who at the time I thought was trying to pull one over me. But not now.
    He said the alternator was charging and showing as charging, but with any load the alternator output would drop. So effectively it was only trickling into the battery, not really fully charging the battery. This (and this is where I thought he was tying to make more money), because the alternator wasn't charging the battery correctly is what also caused the battery to fail. 2 faults. Or 1 fault causing 2. Even though I had had it checked previously.
    I was very sceptical before & after I paid the bill.
    It only took 2 days before I was proven wrong, plus it has now been several months and is still going strong even through our local winter.
    Last edited by Tones9-3; 11-01-2019 at 01:14 AM.

  6. Remove Advertisements
    SaabScene.com
    Advertisements
     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2