Starting issue

  1. Welcome to Saabscene – General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
Results 1 to 6 of 6

Thread: Starting issue

  1. #1
    Saab Junior twoshoes's Avatar
    Join Date
    Feb 2017
    Location
    Lancaster England
    Posts
    40

    Starting issue

    1.9 TID Vector sport estate 2007 150bhp

    A few weeks ago my car started labouring when starting. But even over the past few days -1* its started ok. Today turned key and turn over was slow and lights dim , turned off lights and tried again just clicked. wouldnt start.
    I have a power pack which i had for last car. Put this on to battery and started 1st time.
    Got to work, turned off engine. Tried to start but slow turn over. Message on dash said something like Limited or limitations. Didnt catch all of message. Never had battery charging warning on dash or any warning message . Battery or Alternator or something else??
    Many thanks up front
    Tim
    Regards Tim
    Drive Safe

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2
    Administrator aerojon's Avatar
    Join Date
    Nov 2009
    Location
    Cheshire.Uk
    Posts
    5,044

    Re: Starting issue

    new battery is in order..age of current one..
    My 9-3 audio,2 x cd changers,aux-in & Bluetooth audio streaming..

    Buy cheap pay twice..

  4. #3
    Saabisti
    Join Date
    Dec 2008
    Location
    Leicester
    Posts
    118

    Re: Starting issue

    It may be worth checking the earth lead connection on the battery and at the starter motor. Clean the battery post and clamp.
    I had a similar issue on my 1.9 Tid 8v. The starter was spinning over a bit too slow and drawing too much current. The nice man from the AA found there was a high current draw from the starter and the earth lead had a slight resistance.

    Now the car has 170k and is original starter so i just bought a new one and cleaned up the earth at the same time i fitted the starter. Now starts like a new car, fast and quiet.

  5. #4
    Saab Junior twoshoes's Avatar
    Join Date
    Feb 2017
    Location
    Lancaster England
    Posts
    40
    Bought new battery. Its been on a little under a week, battery not charging warning light has come on. Looks like the alternator is goosed.
    Does anyone know if its a Denso alternator on this model ?
    Regards Tim
    Drive Safe

  6. #5
    Administrator aerojon's Avatar
    Join Date
    Nov 2009
    Location
    Cheshire.Uk
    Posts
    5,044

    Re: Starting issue

    yes it is(denso high failure rate),buy a bosch replacement.
    My 9-3 audio,2 x cd changers,aux-in & Bluetooth audio streaming..

    Buy cheap pay twice..

  7. #6
    Saab Junior twoshoes's Avatar
    Join Date
    Feb 2017
    Location
    Lancaster England
    Posts
    40
    Got car into the garage this afternoon, pick the bloody thing up tomorrow dinner time . Hope its sorted, spent an absolute fortune on it since i got it.
    Oh well it be like new when he's done with it.
    Not sure which one he's got but its £216 plus fitting.
    Regards Tim
    Drive Safe

  8. Remove Advertisements
    SaabScene.com
    Advertisements
     

Similar Threads

  1. 9-5 starting issue
    By dru337 in forum Classic Saab 9-5 (1997 - 2009)
    Replies: 0
    Last Post: 09-18-2015, 03:29 PM
  2. Starting issue
    By CAMVE in forum Saab 9-3 Sport Saloon / Combi(Estate)/TurboX/AWD (2003 - on)/Convertible(2004 - on)
    Replies: 4
    Last Post: 10-16-2014, 12:26 PM
  3. Intermittent Starting Issue...
    By dhartnet in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 6
    Last Post: 01-01-2014, 09:50 AM
  4. Starting Issue
    By Hungry Horace in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 2
    Last Post: 03-13-2013, 10:32 PM
  5. Starting Issue
    By Highaltitudesaab900 in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 0
    Last Post: 09-13-2010, 02:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2