Temp, EDU and fuel gauge problems

  1. Welcome to Saabscene – General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
Results 1 to 4 of 4

Thread: Temp, EDU and fuel gauge problems

  1. #1
    Saabisti
    Join Date
    Mar 2004
    Location
    Derby
    Posts
    149
    1996 2.0 LPT

    Occasional whilst driving I notice that the Temp, EDU and fuel gauge all cut out and the fuel warning light comes on.
    This lasts about 2-3 seconds and then they all return to normal. Speedo and Rev counter all normal. Happened once yesterday and 4 times today.

    Not managed to find anything similar with the search facility.

    Any ideas??

    Mike J

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2
    Saab Afficionado Saviour's Avatar
    Join Date
    May 2003
    Location
    Southampton, UK.
    Posts
    1,513
    1996 2.0 LPT

    Occasional whilst driving I notice that the Temp, EDU and fuel gauge all cut out and the fuel warning light comes on.
    This lasts about 2-3 seconds and then they all return to normal. Speedo and Rev counter all normal. Happened once yesterday and 4 times today.

    Not managed to find anything similar with the search facility.

    Any ideas??

    Mike J[/b]
    Mike, just been reading up on this but cannot find anything. the only thing I could tihnk of, BULBS, but that would not effect the temp & fuel gauges. it would however seem the the edu had turned off, no back light.

  4. #3
    Super Moderator
    Join Date
    Oct 2002
    Location
    Kippen, Stirling
    Posts
    2,673
    Mike,

    What comes to mind is a poor earth connection or a loose edge connector on the back of the dash binnacle. Might be worth whipping of the top of the dash ( don't loose the 5mm washer on the drivers side ) to check for connectors coming slightly loose. Wiggle things about to see if you can reproduce the fault.

    Paul @ Kippen.

  5. #4
    Mike J

    did you ever find out what this was? It's spreading like swineflu!


  6. Remove Advertisements
    SaabScene.com
    Advertisements
     

Similar Threads

  1. temp gauge
    By adebob69 in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 4
    Last Post: 02-04-2011, 04:15 PM
  2. temp gauge
    By overclocker in forum Saab 9000 (1984 - 1998)
    Replies: 6
    Last Post: 12-16-2008, 03:46 PM
  3. MORE temp gauge problems
    By berkbs in forum Saab 9000 (1984 - 1998)
    Replies: 10
    Last Post: 05-28-2007, 07:24 PM
  4. Temp Gauge, Far too Low!
    By Skiddins in forum Saab 9000 (1984 - 1998)
    Replies: 9
    Last Post: 01-28-2003, 04:59 PM
  5. Temp Gauge, Far too Low!
    By Skiddins in forum Saab 9000 (1984 - 1998)
    Replies: 9
    Last Post: 01-28-2003, 04:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2