A/C Not working on '97 Saab 900 SE Torbo
NEWS
 

  1. Welcome to Saabscene General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
+ Reply to Thread
Results 1 to 2 of 2

Thread: A/C Not working on '97 Saab 900 SE Torbo

  1. #1

    A/C Not working on '97 Saab 900 SE Torbo

    My A/c stopped working. I've gone through all of the checks in the owners manual, and did not find a problem. Curiously the ambient temperature gauge is reading about 9 degrees higher than actual. Has anyone experienced this problem? I suspect this may be a coincidence. Is my problem likely to be coolant loss or a malfunction in the compressor clutch?
    Thanks
    Tomlon

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2
    Motor Mouth
    Join Date
    Nov 2002
    Location
    Kent, England
    Posts
    2,041

    Re: A/C Not working on '97 Saab 900 SE Torbo

    Hi Tomlon
    Welcome to Saabscene - probably worth getting the A/C gas checked first especially if it has not been done for some time. There is a pressure switch in the system which cuts off the A/C altogether if the gas pressure has dropped. If there is a leak it can detected by dye in the system when tested. If pure A/C rather than climate control then I don't think the ambient temp is relevant unless about 2 degrees C or freezing when the A/C cuts off.(Can't remember exactly at what point) Others may know more - clutch problems usually present as slippage first and intermittent/poor A/C - Can you hear the clutch clicking in or out at all? Try a search here as adjusting the clutch has been discussed before. This topic may benefit more by being moved to the GM900/9-3 forum where others may view - admin - can you help with this?

    Mike

  4. Remove Advertisements
    SaabScene.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. Nearside full beam, working, then not working
    By peelaaa in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 6
    Last Post: 02-22-2010, 09:54 AM
  2. Saab 93 Brakes not working?
    By Harpal in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 3
    Last Post: 11-21-2008, 04:50 AM
  3. That other Saab site I’m working on….
    By Swade in forum Saab News
    Replies: 0
    Last Post: 10-15-2007, 06:14 AM
  4. Noisy Torbo? Induction? or Dump valve?
    By Pete A in forum Classic Saab 9-5 (1997 - 2009)
    Replies: 8
    Last Post: 08-21-2004, 06:25 PM
  5. Saab 93 Brakes not working?
    By Harpal in forum Help, Advice, Saabs and Motoring
    Replies: 0
    Last Post: 12-31-1969, 07:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2