Limp Mode Comes on at 80mph
NEWS
 

  1. Welcome to Saabscene General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: Limp Mode Comes on at 80mph

  1. #1

    Limp Mode Comes on at 80mph

    Hi have a 93 2.2tid, have back smoke under acceleration and EML comes on at 80mph lose boost power. Have changed MAP sensor last year when it happened in france on the motorway. Also now have cleaned the EGR. Car got to 85 this time but EML and power loss happend again. Any ideas?

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2
    Saabisti justjase's Avatar
    Join Date
    May 2009
    Location
    Yorkshire
    Posts
    154

    Re: Limp Mode Comes on at 80mph

    wonder what happens if it gets to 88mph?

  4. #3
    Saab Afficionado Brennan's Avatar
    Join Date
    Jun 2012
    Location
    Northern Ireland
    Posts
    1,381

    Re: Limp Mode Comes on at 80mph

    Mine does this too I've booked the car in with an auto electrician to be put on the diagnostics machine tomorrow, will keep you updated on the problem

  5. #4
    Saab Junior
    Join Date
    Aug 2012
    Location
    wickford essex england
    Posts
    40

    Re: Limp Mode Comes on at 80mph

    hi i am new to saabs and mine is a petrol 9-3 aero but in my hand book it states that when i reach 143 mph the turbo boost will drop so i do not over speed the engine,i assume there is asensor that monitors what goes on maybe the same applies to your car but it cutting in to early? this may be the fault!!

  6. Remove Advertisements
    SaabScene.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. limp mode
    By shauny598 in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 0
    Last Post: 07-19-2011, 05:00 AM
  2. HELP! Limp Mode
    By adamjamesgrant in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 3
    Last Post: 12-29-2010, 03:06 AM
  3. TCS in limp mode
    By Brock in forum Saab 9000 (1984 - 1998)
    Replies: 7
    Last Post: 05-22-2005, 05:02 AM
  4. TCS in limp mode
    By Brock in forum Saab 9000 (1984 - 1998)
    Replies: 7
    Last Post: 05-22-2005, 05:02 AM
  5. HELP! Limp Mode
    By AJG in forum Help, Advice, Saabs and Motoring
    Replies: 0
    Last Post: 12-31-1969, 07:00 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2