Saab 9-3 2004 2.2 TID Loss of power
NEWS
 

  1. Welcome to Saabscene General discussion forum for Saab

    Welcome to Saabscene - a website dedicated to all things Saab.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Saabscene today!
     
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Thread: Saab 9-3 2004 2.2 TID Loss of power

  1. #1
    Hi All,

    My saab recently lost power, as if the turbo is not working.
    I had it hooked up to a machine and it gave a P1380 Error.
    A saab mechanic said i should try cleaning the EGR valve, which i did, with no luck.
    I have noticed an excessive air noise coming from the exhaust box, the car is not smokey at all.
    Anyone any suggestions as to what could be wrong?

    Thanks in advance for any help

  2. Remove Advertisements
    SaabScene.com
    Advertisements
     

  3. #2
    P1380 is - Glow control unit feedback circuit, short to B+. Check that the plug is firmly on the glow plug control unit correctly (silver box clipped onto the side of the battery tray)

  4. #3
    P1380 is - Glow control unit feedback circuit, short to B+. Check that the plug is firmly on the glow plug control unit correctly (silver box clipped onto the side of the battery tray)[/b]

    Thanks for the reply Merve

    All connections look good, the warning light only ever came on once for a brief period after it had been hooked up to a reader. Any ideas as to why there is a excessive air noise coming from the back box, could it be the cat?
    Driving me mad, driving well just no power at all

  5. #4
    hi, sounds like you have a split turbo boost hose or leaking intercooler, there the most common sources of leaking air noises, that would also cause a loss of power... d.f

  6. #5
    Thanks DRF

    I had checked a few hoses but didnt notice any apparent leaks, just the excessive air noise from what seems the back box.
    I have cleaned the egr valve and removed fuse 17 to clear the codes, better just get it to a saab garage, i could do without the expence at this time of year.
    Im sure they have a charge for just hooking the machine up like nissan.
    But its driving me mad at this stage

  7. #6
    Hi All,

    Just an update on this, didnt do anything with the car over the christmas period due to cash flow.
    I had it looked by a friend who plugged the SAAB computer into it, it gave the following errors.

    P20445B
    P040064
    P0106FA
    P1380B

    He couldnt remember which codes were associated to which error

    Manifold sensor
    EGR
    Turbo solinoid valve [second stage]
    Glow plug wiring loom

    Any suggestions as to which i should do first, Turbo solinoid valve seems most likely as it has some what seems like lower rev turbo.

    Thanks in advance

  8. #7
    Saab Anorak
    Join Date
    Jun 2007
    Location
    bristol
    Posts
    544
    Those symptoms on mine turned out to be a split intercooler. The garage couldn't find the leak until they had removed it.

    All the codes pointed to EGR Valve so I wouldn't put too much faith in the codes.

  9. #8
    So it could be a split pipe, causing the generation of these errors?

  10. #9
    Saab Anorak
    Join Date
    Jun 2007
    Location
    bristol
    Posts
    544
    So it could be a split pipe, causing the generation of these errors?[/b]
    Not necessarily a pipe. Mine was in the intercooler elements.
    The Intercooler is made up the same as a Radiator, just like having a split in the radiator element only air comes out instead of water.

    If you didn't know, the Intercooler sits behind the radiator, same size, there is a gap of a couple if inches between the radiator and intercooler. Radiator nearest the bumper, intercooloer parallel behind it nearest the engine

  11. #10
    Thanks for the info i will check it out.

  12. #11
    Hey Man!,
    had the whole loss of power thing with mine! (04 9-3 2.2tdi)
    Wrecked my head for a bit (suddenly loosing power on the motorway as if the turbo had just went!)
    Hooked it up to a cpu and it said the map sensor was gone! (crazy price to replace!)
    So after a good search through this site I found out that u can usually jst clean the map sensor and EGR valve instead of replacing them!
    Done this (mine were filthy, use carbon cleaner) and car went like new! Id swear there was even a few more hp!!

    Any way, its a easy enuf job!

    Hope it helps!

    Mark.

  13. #12
    Hey Man!,
    had the whole loss of power thing with mine! (04 9-3 2.2tdi)
    Wrecked my head for a bit (suddenly loosing power on the motorway as if the turbo had just went!)
    Hooked it up to a cpu and it said the map sensor was gone! (crazy price to replace!)
    So after a good search through this site I found out that u can usually jst clean the map sensor and EGR valve instead of replacing them!
    Done this (mine were filthy, use carbon cleaner) and car went like new! Id swear there was even a few more hp!!

    Any way, its a easy enuf job!

    Hope it helps!

    Mark.[/b]
    Hi,
    I have a loss of power problem too (53, 9-3 2.2tdi, 102,000miles) but it only seems to occur when trying to get up a steep hill, on flat roads it feels fine but as soon as i hit a hill i have to change right down (depending on the hill gradiant) sometimes to 2nd gear to get up it! In fact on one occasion a couple of weeks ago i had to crawl up a particularly steep hill in 1st gear at about 10mph! It was seriously scary, didnt think i was gonna make it!
    The car isnt using excessive fuel (can go over 40mpg on the trip computer), idles fine not lumpy or fast and seems to pull away fine too, but the engine light comes on and goes off intermittently and i notice a slight sound light air escaping every now and again. I replaced a couple of split pipes a while back (one from the intercooler and the tiny one on top from the turbo) and it drove perfect after that, until now.
    I know it may not be the problem but i was gonna start with cleaning the egr valve but i cant seem to find any info on how to do it on the 2.2tdi (plenty on the 1.9) so having seen your post i thought i would ask if you could give me any advice on where it is and how to do it. Of course any info from anyone would be very much appreciated.

    Thanks in advance

    Nick

  14. #13
    EGR is located at the front right of of the engine bay as you look at it from the front of the car. You need to remove the plastic cover to get to it and is held on by two torx bolts. You also need to remove the coolant clips and pull the hose off - best to use mole grips for that. I removed my torx bolts with a spanner but its best if you use the proper tools! As for cleaning I would probs just replace it as I cleaned mine quite thoroughly but it only lasted 3 months before the engine light came back on again. Mine cost about 200 from a motor factors and has been on almost a year now with no problems. I also replaced all of the small vacuum hoses as they had all cracked a went hard. Later I replaced the MAF sensor as the engine was giving an error code for it. I replaced that with a Pierburg unit for 70 from euro car parts - much cheaper than the bosche original and works very well. I now get 45+mpg with much more power than ever before! I also replaced the air filter which makes a lot of difference as they clog up relatively quickly.

    So far after a lot of problems fingers crossed it seems to be going well but I'm selling her soon whilst the going is good!

  15. #14
    Excellent info, thanks very much, im not even sure that its an egr valve problem but ive had the car 2 and half years now and ive never looked at it so its got to be worth it anyway.
    The engine light is off at the moment, i gave the car a good blast yesterday and on a straight road it goes really well i can feel the turbo pull, it just doesnt seem to be able to cope with a steep incline, very strange!
    When driving the car very steadily back from work today (10 miles) i reset and monitored the mpg on the trip computer and believe it or not it actually got up to 52 mpg at one point, when i arrived home it was showing 44mpg so i dont think there can be that much wrong with it but i woyld like to be able to go up hills without holding my breath!!

    Now youve got your car running well your selling it??? Nah, keep it and enjoy it, Saabs are great(when they work properly!)

    Regards
    Nick

  16. #15
    She's getting sold soon! It has proved way too unreliable and the clutch will soon need replacing. It isn't helped by the fact it has a dual mass flywheel and I don't feel like re-mortgaging my house to replace it on an ageing 2003 car. The exhaust is split at the flexi pipe and the interior is in self destruct mode - i.e. the buttons are rubbing away and it has more rattles than 1960's landrover. Looking at either a Toyota or Lexus next and I'll breathe a sigh of relief when its gone! I've owned a lot of cars of different makes and models and this is the worst one yet. The 2 Toyotas I've had proved totally bullet proof. Not as good in the styling department but where I am in life at the moment with 2 small kids I need reliability over anything!

  17. Remove Advertisements
    SaabScene.com
    Advertisements
     

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Similar Threads

  1. Saab 9-3 power loss - Engine light - Traction issues
    By karlitop in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 3
    Last Post: 01-17-2009, 07:51 PM
  2. 04 Saab 9 3 Loss of power (only in first gear) and EML on
    By Smit1978 in forum Help, Advice, Saabs and Motoring
    Replies: 4
    Last Post: 11-13-2008, 03:51 AM
  3. saab 93 aero '03 power loss & Vibration
    By looselegged in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 1
    Last Post: 01-14-2008, 04:28 PM
  4. Saab GM900 Turbo Power Loss
    By mobile-haven in forum Classic Saab 9-3 & GM900 (1994 - 2002)/Conv ( -2003)
    Replies: 13
    Last Post: 03-18-2005, 07:45 AM
  5. JD Power 2004 Saab reliability: ouch!!
    By 9-3-LPT in forum Saab News
    Replies: 8
    Last Post: 05-07-2004, 07:03 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts